Wednesday, August 12, 2009

Eclipse 3.5 and Flex Builder

Well, today was shot to hell wrestling with Eclipse, Maven and Flex Builder.

Have I mentioned how much i dislike build configuration?

Anyway, I managed to at least get Eclipse and Flex Builder 3 working. It turns out that thats easier then it looks. Here are the steps I used:

(1) Download and install Eclipse 3.5. I used the J2EE install.
(2) Download and run the Flex Builder 3 installer.
(3) Ignore all the warnings that it only supports Eclipse 3.3 and 3.4. Just keep telling it that you know what you are doing and want to install it anyway. It will end with a scary message about failing and suggest you do a manual install from inside of eclipse. Don't do that!
(4) Here is the magic, when it is done there will be a file in your eclipse/links directory called
com.adobe.flexbuilder.feature.core.link
Open that file in wordpad and you will see it contains one line:

C:/Program Files/Adobe/Flex Builder 3 Plug-in

Edit that line so it looks like this:

path=C:/Program Files/Adobe/Flex Builder 3 Plug-in

Save the file and start eclipse. Voilla!

6 comments:

Buey said...

Very nice! Exactly what I was looking for!

Stuart said...

Excellent, this works a treat! Cheers.

Mayhem66 said...

Thanks for saving me that day. It worked first time.

Dimitri said...

Great! You are my hero! (at least for today)

Neven said...

You are God

stephen ogden said...

radical. saved me loads of time. thanks so much!!!!!!!